Paya Payments Outage - 4/11/24
Incident Report for Rev.io, LLC
Resolved
Payments have been flowing successfully since Paya's fix was implemented. At this time, the incident is marked as resolved. For any lingering questions or issues, please reach out to Client Success.
Posted Apr 11, 2024 - 14:45 EDT
Monitoring
Paya has implemented a fix and we are monitoring the results. Please retry any missed payments and reach out to our Client Success team with any questions or continued issues.
Posted Apr 11, 2024 - 12:31 EDT
Update
We are continuing to request info from Paya about their outage and time to resolve. More info will be sent here as soon as we can.
Posted Apr 11, 2024 - 12:04 EDT
Identified
We are receiving reports of payments failures for clients using Paya as their payment processor. Paya has confirmed an outage on their side as the culprit, and are working quickly to restore access and payments flowing. We will keep this thread updated as we receive information. Please refer to Client Success with any questions in the meantime, and thank you for your continued support and patience.

- The Rev.io Team
Posted Apr 11, 2024 - 11:59 EDT
This incident affected: Applications (Rev.io Web).