Microsoft Outlook/365 Outage
Incident Report for Rev.io, LLC
Resolved
Microsoft has resolved their outage and we expect all Outlook connections to resume normal activity. Please reach out to Client Success with any questions or concerns.
Posted Nov 25, 2024 - 19:33 EST
Identified
There is a large-scale Microsoft Outlook/365 outage that may affect users with Outlook email inboxes. Microsoft has not provided any ETA for this being resolved, but we have had reports of intermittent email failures from clients using Outlook inboxes for their Rev.io communication. We are tracking the incident with the DownDetector status page below:

https://downdetector.com/status/outlook/
Posted Nov 25, 2024 - 11:42 EST
This incident affected: Applications (Rev.io Web).