Paya Degraded Performance - October 8th, 2024
Incident Report for Rev.io, LLC
Resolved
This incident has been resolved. For any issues with payments made yesterday during the intermittent outage, please reach out to our Client Success team for assistance.
Posted Oct 09, 2024 - 14:53 EDT
Update
We are continuing to wait for the final 'all-clear' from Paya. They have made progress but have still encountered intermittent slowness/errors. As soon as we have a root cause and final update we will update this thread.
Posted Oct 08, 2024 - 16:00 EDT
Monitoring
A fix has been implemented by Paya and we are monitoring the results. Please reach out to Client Success with any questions. We will provide final guidance here once it's available.
Posted Oct 08, 2024 - 14:48 EDT
Investigating
We are currently investigating reports of payments errors when attempting to make payments using Paya. We have reached out to their team for guidance, and have involved our Engineering team as well. As soon as more info is available, we will update this incident page. Please reach out to Client Success with any concerns or questions, and thanks for your attention to this matter.
Posted Oct 08, 2024 - 14:24 EDT
This incident affected: Applications (Rev.io Web).