CSI Taxation Engine Outage
Incident Report for Rev.io, LLC
Resolved
We have seen stable connections with CSI since their outage was resolved. As of this time we don't have any insight into the reason for the outage that the CSI tax engine experienced from 1/27-1/30. For this reason we ask that any questions be directed to CSI until a root cause is provided. Once a root cause is provided to rev.io we may ask that you take precautionary actions if the root cause warrants such a response.
Posted Feb 02, 2024 - 12:49 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 31, 2024 - 09:11 EST
Update
We are monitoring the results of the fix from CSI, and at this time taxes are flowing again. We highly recommend all clients who use CSI to run test transactions and validate taxes are correct via your team and/or tax compliance partner.
Posted Jan 31, 2024 - 09:11 EST
Monitoring
A fix has been implemented by CSI and they have provided the following guidance:

Incident status: Monitoring
Our Tax Rating APIs are now online using the same endpoints you currently have. We had to change the IP addresses of the systems, so it may take some time for the DNS to propagate throughout the world. If you would like the new IP address of the endpoint, please contact me at dcazel@sybellius.net. Thank you for your patience.
Posted Jan 30, 2024 - 21:44 EST
Update
We are still waiting for CSI to resolve the outage, please refer to their status page for the most up to date information. For any clients who use CSI and also bill on the 1st of the month, we are offering to disable billing automation until the CSI outage is resolved. Reach out to Client Success with any questions or needs and thanks for your continued patience.
Posted Jan 30, 2024 - 15:55 EST
Update
At this time, CSI is still down. They have provided the following update, pasted below.

"Update - Still working to bring up the tax calc APIs at a minimum level for tax rating. Have faced several complications in this regard."
Posted Jan 30, 2024 - 08:24 EST
Update
We received the following update from CSI:

Update - We are in QC process and are continuing to make progress on providing tax rating capabilities through our APIs. Currently, it appears we will have functionality restored later tonight. Will provide another update as we get closer. Thank you for your patience.
Posted Jan 29, 2024 - 20:49 EST
Update
We have spoken with CSI, and they are hopeful to have the outage resolved this evening. Our hope is for taxes to be flowing by the end of business today, but if not it should resume tomorrow morning. CSI is doing everything they can to restore service soon and are thankful for the patience from our clients. As soon as more info is available, it will be updated and distributed here.
Posted Jan 29, 2024 - 14:52 EST
Update
At this time we are still waiting on CSI to resolve their outage. We have not gotten a firm timeline from their team, and are hoping for resolution. Orders, charges, and bills will still be affected for any client using CSI until the outage is resolved.

Please refer to CSI's status page as well as ours for any updates as they become available.

https://compliancesolutionsinc.statuspage.io/incidents/xbwrsmypkfnt
Posted Jan 29, 2024 - 13:27 EST
Update
CSI's team is continuing to work on the issues from their side, and will provide another update this afternoon. Thank you for your patience as we wait for CSI to resolve their outage.
Posted Jan 29, 2024 - 12:41 EST
Identified
CSI has identified the issue and is working to resolve it. We hope to have service restored by their team in the next 2 hours. As soon as we hear more information we will pass it along. CSI has created a status page as well, located here:

https://compliancesolutionsinc.statuspage.io/
Posted Jan 29, 2024 - 11:16 EST
Update
We are continuing to wait for guidance from the CSI and an estimated time for resolution. As soon as more information is received, we will update this thread.
Posted Jan 29, 2024 - 10:00 EST
Investigating
We are currently receiving reports that clients who use CSI as their tax engine are not producing taxes on products or bills currently. CSI appears to be having an outage upstream from our platform. We have reached out to the CSI team for guidance and assistance. At this time, clients using CSI will be unable to run bills or create taxes until CSI has resolved the issue. We'll monitor closely and hope the CSI team is able to fix it quickly. Reach out to Client Success with any questions.
Posted Jan 29, 2024 - 08:26 EST
This incident affected: Applications (Rev.io Web).