Suretax Site Down
Incident Report for Rev.io, LLC
Resolved
This incident has been resolved. Billing has been enabled for all clients again. Any transactions made between 11:00am 5/6 and 6:00pm 5/7 will need to be recreated, including any bill runs. If you have any questions, please contact the support team at 866-470-5502 and press 1.
Posted May 08, 2019 - 08:21 EDT
Monitoring
Suretax's system has been restored and Rev.io is working diligently to recreate any invoices, credits, and bills that were affected by the Suretax outage.

We appreciate your patience during this time.

---
Message from Suretax:

"We have been able to restore network and services for CCH Suretax.

We also wanted to share the most recent update. Certain Wolters Kluwer platforms and applications have been experiencing service interupptions since Monday. We want to apologize for any inconvenience this may have caused.

On Monday May 6, we started seeing technical anomalies in a number of out platforms and applications. Our team immediately started investigating and discovered the installations of malware. As a precaution, in parallel, we decided to take a broader range of platforms and applications offline. With this action, we aimed to quickly limit the impact this malware could have had, giving us the opportunity to investigate the issue with assistance from third-party forensics consultants and work on a solution. Unfortunately, this impacted our communication channels and limited our ability to share updates. On May 7, we were able to restore service to a number of applications and platforms.

While taking our services offline was precautionary, we wanted to act quickly to protect our applications. We regret any inconvenience and that we were unable to share more information initially, as our focus was on investigation and restoring services as quickly as possible for our customers.

We have seen no evidence that customer data was taken or that there was a breach of confidentiality of that data. Also, there is no reason to believe that our customers have been infected through our platforms and applications. Our investigations is ongoing. We are still investigating the root cause of the interruption. Please reach out to your account manager in case of any questions.

We sincerely apologize for the inconvenience.

The Wolters Kluwer Support Team"
Posted May 07, 2019 - 22:39 EDT
Update
Suretax is still undergoing unscheduled maintenance and their technical teams are working to restore systems.

Rev.io has disabled billing for all clients using Suretax until the issue has been resolved to avoid sending bills out with no taxes. Once Suretax's system is back up, Rev.io will enable billing and ensure all charges post with the appropriate taxes so bills can be sent out.

We will provide updates here as soon as we get information from Suretax.

We appreciate your patience during this time.
Posted May 07, 2019 - 13:27 EDT
Identified
Suretax is undergoing unscheduled maintenance and their technical teams are working to restore systems.

Unfortunately, during this time certain Rev.io functionality will be affected. Any feature or service that requires Rev.io to check tax information from Suretax will be down until Suretax's system is restored.

We will provide updates here as soon as we get information from Suretax.

We appreciate your patience during this time.
Posted May 06, 2019 - 19:36 EDT
This incident affected: Applications (Rev.io Web, SOAP API, REST API, AgentClick Web) and Processes (Recurring Billing).